summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-22 16:29:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 20:51:21 -0400
commitb3ac513f4876bfccb75d76d237786380001fc1cf (patch)
tree64f7e829e7d0d9dd03ec54edf94ffbd6c3d79089 /gnu/packages
parentffef7c01f030057ed835ba62faf4b5923a8049d1 (diff)
gnu: clutter: Update to 1.26.4 and remove input labels.
* gnu/packages/gnome.scm (clutter): Update to 1.26.4. [native-inputs]: Remove labels. [propagated-inputs, inputs]: Sort inputs. [home-page]: Update URL.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8ca955db2a..29a36d111d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5922,7 +5922,7 @@ without stepping on each others toes.")
(define-public clutter
(package
(name "clutter")
- (version "1.26.2")
+ (version "1.26.4")
(source
(origin
(method url-fetch)
@@ -5931,31 +5931,31 @@ without stepping on each others toes.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0mif1qnrpkgxi43h7pimim6w6zwywa16ixcliw0yjm9hk0a368z7"))))
+ "1rn4cd1an6a9dfda884aqpcwcgq8dgydpqvb19nmagw4b70zlj4b"))))
;; NOTE: mutter exports a bundled fork of clutter, so when making changes
;; to clutter, corresponding changes may be appropriate in mutter as well.
(build-system gnu-build-system)
(outputs '("out"
- "doc")) ;9 MiB of gtk-doc HTML pages
+ "doc")) ;9 MiB of gtk-doc HTML pages
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-genmarshal
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
+ (list `(,glib "bin") ; for glib-genmarshal
+ gobject-introspection
+ libxslt
+ pkg-config))
(propagated-inputs
- (list cogl
+ (list atk
cairo
- atk
+ cogl
+ glib
gtk+
json-glib
- glib
libxcomposite
libxdamage
libxext
xinput))
(inputs
- `(("libxkbcommon" ,libxkbcommon)
- ("udev" ,eudev)))
+ (list eudev
+ libxkbcommon))
(arguments
`(#:configure-flags (list "--enable-x11-backend=yes"
@@ -5966,7 +5966,7 @@ without stepping on each others toes.")
;; XXX FIXME: Get test suite working. It would probably fail in the
;; same way the cogl tests fail, since clutter is based on cogl.
#:tests? #f))
- (home-page "http://www.clutter-project.org")
+ (home-page "https://blogs.gnome.org/clutter/")
(synopsis "OpenGL-based interactive canvas library")
(description
"Clutter is an OpenGL-based interactive canvas library, designed for