summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-18 22:31:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-24 10:45:51 +0300
commitc59a06152f114dc1872c33cb8b5471fb91adb2d0 (patch)
treefeb22eafce764de6818b87d0e0ac3b93e9ffe0c9 /gnu/packages
parent1ae72fac346e76f9863529ccb331f5d9b27654bf (diff)
gnu: Remove rust-eax-0.3.
* gnu/packages/crates-io.scm (rust-eax-0.3): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index be39ce31b0..180d399f6c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19705,37 +19705,6 @@ from the main thread.")
easy.")
(license (list license:unlicense license:zlib))))
-(define-public rust-eax-0.3
- (package
- (name "rust-eax")
- (version "0.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "eax" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0vmpbqncpbj2ldm3fhfz87ija1sk4zk9vad91yd2jjsrbrx6xxz1"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-aead" ,rust-aead-0.3)
- ("rust-cipher" ,rust-cipher-0.2)
- ("rust-cmac" ,rust-cmac-0.5)
- ("rust-ctr" ,rust-ctr-0.6)
- ("rust-subtle" ,rust-subtle-2))))
- (home-page "https://docs.rs/eax/")
- (synopsis "Pure Rust implementation of the EAX Authenticated Encryption
-with Associated Data (AEAD)")
- (description "This package provides a pure Rust implementation of the EAX
-Authenticated Encryption with Associated Data (AEAD) Cipher with optional
-architecture-specific hardware acceleration. This scheme is only based on a
-block cipher. It uses counter mode (CTR) for encryption and CBC mode for
-generating a OMAC/CMAC/CBCMAC (all names for the same thing).")
- (license (list license:asl2.0 license:expat)))) ; at your choice
-
(define-public rust-ecies-ed25519-0.5
(package
(name "rust-ecies-ed25519")