summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-11-04 12:32:14 +0300
committerLudovic Courtès <ludo@gnu.org>2023-11-25 23:35:02 +0100
commitcad061327ebbde79ca56cc56b5554372a6af1e62 (patch)
tree094a2fecc5c8481271e2d75d93e4ef48685b1b8a /gnu/packages
parentb9c8f3784aa4353de40aef3b8e81a40e5decc585 (diff)
gnu: Deprecate the "go-github-com-willf-bitset" variable.
* gnu/packages/golang.scm (go-github-com-willf-bitset): Rename to "go-github-com-bits-and-blooms-bitset". [arguments]: Update. [home-page]: Update. (go-github-com-willf-bitset): Define as deprecated by "go-github-com-bits-and-blooms-bitset". Change-Id: Iaa31f120d1c2b18a5c916ea5e68b89bd3e534ffd Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ffac94854f..6d23ade32a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8648,29 +8648,32 @@ directories. It is optimized for filewalking.")
@code{database/sql}.")
(license license:expat)))
-(define-public go-github-com-willf-bitset
+(define-public go-github-com-bits-and-blooms-bitset
(package
- (name "go-github-com-willf-bitset")
+ (name "go-github-com-bits-and-blooms-bitset")
(version "1.1.10")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/willf/bitset")
- (commit (string-append "v" version))))
+ (url "https://github.com/bits-and-blooms/bitset")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0wpaxg6va3qwd0hq0b8rpb1hswvzzbfm2h8sjmcsdpbkydjjx9zg"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/willf/bitset"))
+ '(#:import-path "github.com/bits-and-blooms/bitset"))
(synopsis "Bitsets in Go")
(description "This package provides a Go implementation of bitsets, which
are a mapping between non-negative integers and boolean values focused on
efficient space usage.")
- (home-page "https://github.com/willf/bitset")
+ (home-page "https://github.com/bits-and-blooms/bitset")
(license license:bsd-3)))
+(define-public go-github-com-willf-bitset
+ (deprecated-package "go-github-com-willf-bitset" go-github-com-bits-and-blooms-bitset))
+
(define-public go-github-com-willf-bloom
(package
(name "go-github-com-willf-bloom")