summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:05:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:05:38 +0200
commitcc741da87ad98aefea1586b4f7aba3596b2d2984 (patch)
treeff6fdffd571dfda2e367c8e3a36af1613c8eeb4b /gnu/packages
parent319aa5fbbcb7d2c4124bab0349254abe711f1124 (diff)
gnu: Add texlive-pxufont.
* gnu/packages/tex.scm (texlive-pxufont): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 27c7a0cb15..b0f6e55a34 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15221,6 +15221,36 @@ technical note @emph{Requirements for Japanese Text Layout} and the JIS
specification JIS X 4051.")
(license license:expat)))
+(define-public texlive-pxufont
+ (package
+ (name "texlive-pxufont")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pxufont/"
+ "fonts/tfm/public/pxufont/"
+ "fonts/vf/public/pxufont/"
+ "tex/latex/pxufont/")
+ (base32
+ "167hmw73lxgsv27gkzanr1plalsqfxphknl8q3rbamy2zp6n0al0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pxufont")
+ (synopsis "Emulate non-Unicode Japanese fonts using Unicode fonts")
+ (description
+ "The set of the Japanese logical fonts (JFMs) that are used as standard
+fonts in pTeX and upTeX contains both Unicode JFMs and non-Unicode JFMs. This
+bundle provides an alternative set of non-Unicode JFMs that are tied to the
+virtual fonts (VFs) that refer to the glyphs in the Unicode JFMs. Moreover it
+provides a LaTeX package that redefines the NFSS settings of the Japanese
+fonts of @code{(u)pLaTeX} so that the new set of non-Unicode JFMs will be
+employed. As a whole, this bundle allows users to dispense with the mapping
+setup on non-Unicode JFMs. Such a setup is useful in particular when users
+want to use OpenType fonts (such as Source Han Serif) that have a glyph
+encoding different from Adobe-Japan1, because mapping setups from non-Unicode
+JFMs to such physical fonts are difficult to prepare.")
+ (license license:expat)))
+
(define-public texlive-pwebmac
(package
(name "texlive-pwebmac")