summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-06 23:13:04 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:23 -0400
commitcd7fedb2bf541c8bea805bf88026f252ef924315 (patch)
tree2e4eeed526a2f2961d4ad41f1efe542f05cdcee2 /gnu/packages
parentd64d4ee2957d5b550675a7393e4d310fcc5091ca (diff)
gnu: Add ruby-subprocess.
* gnu/packages/ruby.scm (ruby-subprocess): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a6de41b4d6..2934808169 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12226,6 +12226,27 @@ development kit for Ruby.")
(home-page "https://github.com/mtsmfm/language_server-protocol-ruby")
(license license:expat)))
+(define-public ruby-subprocess
+ (package
+ (name "ruby-subprocess")
+ (version "1.5.6")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "subprocess" version))
+ (sha256
+ (base32
+ "0v49ahfx9b75qg42sl8a3l367g2vihc16g8z5f2raxpxjl1wh2s2"))))
+ (build-system ruby-build-system)
+ ;; Do not run the test suite, as there its test dependency ruby-sord would
+ ;; introduce a cycle with ruby-sorbet-runtime.
+ (arguments (list #:tests? #f))
+ (native-inputs (list ruby-minitest ruby-pry))
+ (synopsis "Ruby library to control and communicate with spawned processes")
+ (description "This Ruby library is controlling and communicating with
+spawned processes. It is designed after Python's @code{subprocess} module.")
+ (home-page "https://github.com/stripe/subprocess")
+ (license license:expat)))
+
(define-public ruby-syntax-tree
(package
(name "ruby-syntax-tree")