summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:17:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:17:25 +0200
commitd631be5b668fe8e9a7e079e5d8ee6551ea6af041 (patch)
treec31075873e08c8d115f05d4da76a0d2b5873f7e0 /gnu/packages
parent3519d2a5793a23fafb6f33b83800f6d60a3cff38 (diff)
gnu: Add texlive-ifxptex.
* gnu/packages/tex.scm (texlive-ifxptex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 43780ff9da..61bbd55236 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -28254,6 +28254,26 @@ the engine in use.")
(define-deprecated-package texlive-generic-iftex texlive-iftex)
(define-deprecated-package texlive-generic-ifxetex texlive-iftex)
+(define-public texlive-ifxptex
+ (package
+ (name "texlive-ifxptex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/ifxptex/"
+ "tex/generic/ifxptex/")
+ (base32
+ "0r77j010a9fcn47kjy6vwv72i8fynb8jsilas6hs9c9lgk5bal1g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ifxptex")
+ (synopsis "Detect pTeX and its derivatives")
+ (description
+ "The package provides commands for detecting pTeX and its derivatives
+(e-pTeX, upTeX, e-upTeX, and ApTeX). Both LaTeX and plain TeX are
+supported.")
+ (license license:knuth)))
+
(define-public texlive-tipa
(package
(name "texlive-tipa")