summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 22:51:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:47 +0200
commite2d105a1f6866aeb511a708b454f52db1e3c9305 (patch)
treed55bd00ed1229af4f62ab826c0bbf90f35f10845 /gnu/packages
parentc5b02655200954326641825602cdffb7879f885c (diff)
gnu: texlive-capt-of: Refresh package definition.
* gnu/packages/tex.scm (texlive-capt-of): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 16 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 97613e6595..a749af7118 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5970,28 +5970,23 @@ including files to the root of the tree). The package supersedes FiNK.")
(license license:public-domain)))
(define-public texlive-capt-of
- (let ((template
- (simple-texlive-package
- "texlive-capt-of"
- (list "doc/latex/capt-of/"
- "source/latex/capt-of/"
- "tex/latex/capt-of/")
- (base32 "0bf0cdd9ca3kkqxqqkq6jalh5ybs60l80l5gfkl2whk2v4bnzfvz"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "latex/capt-of")
- ((#:build-targets _ '())
- '(list "capt-of.ins"))))
- (home-page "https://www.ctan.org/pkg/capt-of")
- (synopsis "Captions on more than floats")
- (description
- "This package defines a command @code{\\captionof} for putting a caption
+ (package
+ (name "texlive-capt-of")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/capt-of/" "source/latex/capt-of/"
+ "tex/latex/capt-of/")
+ (base32
+ "0bf0cdd9ca3kkqxqqkq6jalh5ybs60l80l5gfkl2whk2v4bnzfvz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://www.ctan.org/pkg/capt-of")
+ (synopsis "Captions on more than floats")
+ (description
+ "This package defines a command @code{\\captionof} for putting a caption
to something that's not a float.")
- (license license:lppl))))
+ (license license:lppl)))
(define-deprecated-package texlive-latex-capt-of texlive-capt-of)