summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:26 +0200
commitfaea84bf6571769385a7a86a1fadc20e2232fefa (patch)
treefcb6a75c7e418a8645cf21c67e87b3d0cafe1307 /gnu/packages
parentc5829570a8dd7699ede50199a06cb1cf966c3d45 (diff)
gnu: Add trytond-account-statement-ofx.
* gnu/packages/tryton.scm (trytond-account-statement-ofx): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7410d4c3d7..0a16fe9d76 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1051,6 +1051,32 @@ the import of @emph{CODA} files as statement. @emph{CODA} is a standard
defined by Belgian \"febelfin\".")
(license license:gpl3+)))
+(define-public trytond-account-statement-ofx
+ (package
+ (name "trytond-account-statement-ofx")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_statement_ofx" version))
+ (sha256
+ (base32 "1n24lwp1lfw59xdd7mqaz6ncr5b0bldr2qniqdnkvyaav0h8h5px"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_statement_ofx"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("python-ofxparse" ,python-ofxparse)
+ ("trytond" ,trytond)
+ ("trytond-account-statement" ,trytond-account-statement)
+ ("trytond-bank" ,trytond-bank)
+ ("trytond-party" ,trytond-party)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-account-statement-ofx")
+ (synopsis "Tryton module to import OFX statements")
+ (description "The @emph{Account Statement OFX} Tryton module implements
+the import of the @emph{OFX} files as statement.")
+ (license license:gpl3+)))
+
(define-public trytond-analytic-account
(package
(name "trytond-analytic-account")