summaryrefslogtreecommitdiff
path: root/gnu/services/lightdm.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/services/lightdm.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm
Diffstat (limited to 'gnu/services/lightdm.scm')
-rw-r--r--gnu/services/lightdm.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/services/lightdm.scm b/gnu/services/lightdm.scm
index 07f2e808dd..7e3864fec2 100644
--- a/gnu/services/lightdm.scm
+++ b/gnu/services/lightdm.scm
@@ -40,7 +40,6 @@
#:use-module (guix records)
#:use-module (ice-9 format)
#:use-module (ice-9 match)
- #:use-module (oop goops)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
#:export (lightdm-seat-configuration
@@ -177,17 +176,18 @@ Provider Interface (AT-SPI).")
"Extra configuration values to append to the LightDM GTK Greeter
configuration file."))
-(define (strip-class-name-brackets name)
- "Remove the '<<' and '>>' brackets from NAME, a symbol."
- (let ((name* (symbol->string name)))
- (if (and (string-prefix? "<<" name*)
- (string-suffix? ">>" name*))
- (string->symbol (string-drop (string-drop-right name* 2) 2))
- (error "unexpected class name" name*))))
+(define (strip-record-type-name-brackets name)
+ "Remove the '<' and '>' brackets from NAME, a symbol."
+ (let ((name (symbol->string name)))
+ (if (and (string-prefix? "<" name)
+ (string-suffix? ">" name))
+ (string->symbol (string-drop (string-drop-right name 1) 1))
+ (error "unexpected record type name" name))))
(define (config->name config)
"Return the constructor name (a symbol) from CONFIG."
- (strip-class-name-brackets (class-name (class-of config))))
+ (strip-record-type-name-brackets
+ (record-type-name (struct-vtable config))))
(define (greeter-configuration->greeter-fields config)
"Return the fields of CONFIG, a greeter configuration."
@@ -323,7 +323,7 @@ a symbol."
(define (list-of-greeter-configurations? greeter-configs)
(and ((list-of greeter-configuration?) greeter-configs)
;; Greeter configurations must also not be provided more than once.
- (let* ((types (map (cut (compose class-name class-of) <>)
+ (let* ((types (map (compose record-type-name struct-vtable)
greeter-configs))
(dupes (filter (lambda (type)
(< 1 (count (cut eq? type <>) types)))
@@ -374,7 +374,7 @@ security:
\" -SecurityTypes None\" ))
@end lisp
-Or to set a PasswordFile for the classic (unsecure) VncAuth mecanism:
+Or to set a PasswordFile for the classic (unsecure) VncAuth mechanism:
@lisp
(vnc-server-command
(file-append tigervnc-server \"/bin/Xvnc\"