summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-07 21:48:36 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:18 +0100
commit05c2fd3685adc7f4257606e9a7f6d28753047352 (patch)
treed019216342190d4d6867a549f2f4eeb8223b1067 /gnu
parent6151120a71507017bfea82693c7e614b341e50e7 (diff)
gnu: python-pytest-flakes: Fix build.
* python.scm (python-pytest-flakes): Set PYTHONPATH prior to running tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fb5d2fd16a..a22be5c794 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10960,7 +10960,10 @@ failures.")
(modify-phases %standard-phases
(delete 'check)
(add-after 'install 'check
- (lambda _ ; It's easier to run tests after install.
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; It's easier to run tests after install.
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
(zero? (system* "py.test" "-vv")))))))
(native-inputs
`(("python-coverage" ,python-coverage)