summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-11 17:11:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-11 17:12:54 +0200
commit061693964192dea4ec6c2354142a2ad27f670669 (patch)
tree27fa35d182eb00703bed15490874c27367bb4a4c /gnu
parent0a8c46e89f095a9ec3632d43920ac3cce49f16d5 (diff)
gnu: Add python-docrep.
* gnu/packages/python-xyz.scm (python-docrep): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5fe5b31979..e50a8b813d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -583,6 +583,26 @@ and variables you'll need already imported and created.
scipy and numpy of negative binomial maximum likelihood estimation.")
(license license:gpl3+)))
+(define-public python-docrep
+ (package
+ (name "python-docrep")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "docrep" version))
+ (sha256
+ (base32
+ "0523jrzjj29kxpdllmfhrfj9kysi9mphp2m7ippjkn5b07i1g2pd"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-six))
+ (native-inputs (list python-pytest python-pytest-runner))
+ (home-page "https://github.com/Chilipp/docrep")
+ (synopsis "Python package for docstring repetition")
+ (description "Docrep is the documentation repetition module. This module
+targets developers that develop complex and nested Python APIs and helps them
+to create a well-documented piece of software.")
+ (license license:asl2.0)))
+
(define-public python-dotmap
(package
(name "python-dotmap")