summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-02-06 13:49:34 -0500
committerTimothy Sample <samplet@ngyro.com>2022-03-19 13:33:06 -0600
commit0db2a6e74952ee2c99d47e9580aac9d7fe657b16 (patch)
tree867b4ee9a93a475fcf9416a30aadd0feef167295 /gnu
parent5268bd97b15f0f2ebf7b5a74ccbc84d9f6462921 (diff)
gnu-bootstrap: Allow multiple module directories.
* guix/build/gnu-bootstrap.scm (bootstrap-configure, bootstrap-build, bootstrap-install): Treat the 'modules' argument as a list of directories. * gnu/packages/commencement.scm (bootar, gash-boot, gash-utils-boot): Adjust call sites.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 644db8cc58..fd3a9c37e7 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -121,9 +121,9 @@
(invoke guile "--no-auto-compile" source)
(chdir "bootar"))))
(replace 'configure (bootstrap-configure "Bootar" ,version
- "." "scripts"))
- (replace 'build (bootstrap-build "."))
- (replace 'install (bootstrap-install "." "scripts"))))))
+ '(".") "scripts"))
+ (replace 'build (bootstrap-build '(".")))
+ (replace 'install (bootstrap-install '(".") "scripts"))))))
(inputs `(("guile" ,%bootstrap-guile)))
(home-page "https://git.ngyro.com/bootar")
(synopsis "Tar decompression and extraction in Guile Scheme")
@@ -158,9 +158,9 @@ pure Scheme to Tar and decompression in one easy step.")
(modify-phases %standard-phases
(replace 'configure
(bootstrap-configure "Gash" ,(package-version gash)
- "gash" "scripts"))
- (replace 'build (bootstrap-build "gash"))
- (replace 'install (bootstrap-install "gash" "scripts"))
+ '("gash") "scripts"))
+ (replace 'build (bootstrap-build '("gash")))
+ (replace 'install (bootstrap-install '("gash") "scripts"))
(add-after 'install 'install-symlinks
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -222,9 +222,9 @@ pure Scheme to Tar and decompression in one easy step.")
(delete-file "scripts/template.in")))
(replace 'configure
(bootstrap-configure "Gash-Utils" ,(package-version gash-utils)
- "gash" "scripts"))
- (replace 'build (bootstrap-build "gash"))
- (replace 'install (bootstrap-install "gash" "scripts"))
+ '("gash") "scripts"))
+ (replace 'build (bootstrap-build '("gash")))
+ (replace 'install (bootstrap-install '("gash") "scripts"))
;; XXX: The scripts should add Gash to their load paths and
;; this phase should not exist.
(add-after 'install 'copy-gash