summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 15:09:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 15:29:22 +0200
commit15b35874b104723c5f1bf39a92469c43e514350f (patch)
treef8cd346c120fc3bd03d8e85babc9d7334cee299b /gnu
parentc63da4eb52860d50c01213addc274cc2a373d3ac (diff)
gnu: Add r-ggtreeextra.
* gnu/packages/bioconductor.scm (r-ggtreeextra): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index af0f39aa8d..17ad509197 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10619,6 +10619,36 @@ expressed genes in DNA microarray experiments.")
fitting of some classes of graphical Markov models.")
(license license:gpl2+)))
+(define-public r-ggtreeextra
+ (package
+ (name "r-ggtreeextra")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ggtreeExtra" version))
+ (sha256
+ (base32
+ "19xikly6ksh03kgpz35wj2d2gdbpikhrk71ahj9ghhkmlwdyjbcr"))))
+ (properties `((upstream-name . "ggtreeExtra")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-cli
+ r-ggnewscale
+ r-ggplot2
+ r-ggtree
+ r-magrittr
+ r-rlang
+ r-tidytree))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/YuLab-SMU/ggtreeExtra/")
+ (synopsis
+ "Add geometric layers On circular or other layout tree of ggtree")
+ (description
+ "ggtreeExtra extends the method for mapping and visualizing associated
+data on phylogenetic tree using ggtree. These associated data can be
+presented on the external panels to circular layout, fan layout, or other
+rectangular layout tree built by ggtree with the grammar of ggplot2.")
+ (license license:gpl3+)))
+
;; This is a CRAN package, but it depends on a bunch of Bioconductor packages.
(define-public r-ggpicrust2
(package