summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-17 19:22:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:50 +0300
commit1ae1c3a378e510fb8315044d31ed7785ea52e546 (patch)
treeccb29e3c3744d0dacd0ba1fd0d676987fba894ce /gnu
parent6e60270317be77a9affc3abc2d14907fee939d54 (diff)
gnu: Remove rust-postgres-shared-0.4.
* gnu/packages/crates-io.scm (rust-postgres-shared-0.4): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6d889c3227..1b133d08eb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45588,41 +45588,6 @@ overloading without macros in Rust.")
("rust-sha2" ,rust-sha2-0.7)
("rust-stringprep" ,rust-stringprep-0.1))))))
-(define-public rust-postgres-shared-0.4
- (package
- (name "rust-postgres-shared")
- (version "0.4.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "postgres-shared" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0vzk1njkqkd2xxz34jnax29z4179ni4j3f534i6416q2w2rkbb7z"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-bit-vec" ,rust-bit-vec-0.4)
- ("rust-chrono" ,rust-chrono-0.4)
- ("rust-eui48" ,rust-eui48-0.3)
- ("rust-fallible-iterator" ,rust-fallible-iterator-0.1)
- ("rust-geo" ,rust-geo-0.4)
- ("rust-hex" ,rust-hex-0.2)
- ("rust-phf" ,rust-phf-0.7)
- ("rust-postgres-protocol" ,rust-postgres-protocol-0.3)
- ("rust-rustc-serialize" ,rust-rustc-serialize-0.3)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-time" ,rust-time-0.1)
- ("rust-uuid" ,rust-uuid-0.5))))
- (home-page "https://github.com/sfackler/rust-postgres")
- (synopsis
- "Internal crate used by @code{postgres} and @code{postgres-tokio}")
- (description
- "This is an internal crate used by @code{postgres} and
-@code{postgres-tokio}.")
- (license license:expat)))
-
(define-public rust-postgres-types-0.2
(package
(name "rust-postgres-types")