summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:42:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:14 +0200
commit25b88b9f221c392ce476b63947169b5ca807dc79 (patch)
treebf639460fcb24ce14e7756033b6be11b13dfa7e3 /gnu
parent3c5aa3b427fcb995db998cc856438b7e11e28aee (diff)
gnu: Add texlive-pseudo.
* gnu/packages/tex.scm (texlive-pseudo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b07b942ffe..862ebf5ace 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5647,6 +5647,27 @@ A cross-referencing system is provided for trees which cite line numbers in
justifications for proof lines or branch closures.")
(license license:lppl1.3+)))
+(define-public texlive-pseudo
+ (package
+ (name "texlive-pseudo")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pseudo/" "tex/latex/pseudo/")
+ (base32
+ "0dc97v66hilgnl9m7rbr737lb4vy08fwdjs4ldcvvmrk2da026xb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pseudo")
+ (synopsis "Straightforward pseudocode")
+ (description
+ "The package permits writing pseudocode without much fuss and with quite
+a bit of configurability. Its main environment combines aspects of
+enumeration, tabbing and tabular for nonintrusive line numbering, indentation
+and highlighting, and there is functionality for typesetting common syntactic
+elements such as keywords, identifiers, and comments.")
+ (license license:expat)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")