summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 18:57:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:14:32 +0200
commit2a75e7f06e7e007c5ab796ae09e4ea1f609bb07f (patch)
tree9c2e6c620f9ab7b5d69697eebabd8f642131c7dd /gnu
parent335f7d069765e5ec34dfff148abeccac86c54f70 (diff)
gnu: Add texlive-kotex-utils.
* gnu/packages/tex.scm (texlive-kotex-utils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d593c0a635..a98d6717e0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7133,6 +7133,31 @@ UTF-8.")
language; input Korean text should be encoded in UTF-8.")
(license license:lppl1.3c)))
+(define-public texlive-kotex-utils
+ (package
+ (name "texlive-kotex-utils")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/kotex-utils/"
+ "makeindex/kotex-utils/"
+ "scripts/kotex-utils/")
+ (base32
+ "01qmr50fr3i2gzgjyj69jgj4czf62s22z58kja6hbqygczc1jba3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:link-scripts
+ #~(list "jamo-normalize.pl" "komkindex.pl" "ttf2kotexfont.pl")))
+ (inputs (list perl))
+ (propagated-inputs (list texlive-kotex-utf))
+ (home-page "https://ctan.org/pkg/kotex-utils")
+ (synopsis "Utility scripts and support files for typesetting Korean")
+ (description
+ "The bundle provides scripts and support files for index generation in
+Korean language typesetting.")
+ (license license:lppl)))
+
(define-public texlive-knuth-errata
(package
(name "texlive-knuth-errata")