summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:46:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:32 +0200
commit3d0d48664f9a00569d6227f24e4cb1b765a71996 (patch)
treec7165a974fc260167d4d53106df06ce31acb6c6d /gnu
parent46f300eb44ddc0478711e2d6c0851112fa7caeea (diff)
gnu: Add texlive-obnov.
* gnu/packages/tex.scm (texlive-obnov): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6fc562db97..50bac2d70d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -20030,6 +20030,30 @@ of fonts, designed by Vernon Adams.")
"The package will typeset both Z and Object-Z specifications.")
(license license:lppl)))
+(define-public texlive-obnov
+ (package
+ (name "texlive-obnov")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/obnov/"
+ "fonts/source/public/obnov/"
+ "fonts/tfm/public/obnov/" "tex/latex/obnov/")
+ (base32
+ "0hjc381fw38qr7rkj137d5rp2jjv002g29bx5g3jjaxl9civvplq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/obnov")
+ (synopsis "Obyknovennaya Novaya fonts")
+ (description
+ "The Obyknovennaya Novaya (Ordinary New Face) typeface was widely used in
+the USSR for scientific and technical publications, as well as textbooks. The
+fonts are encoded to KOI8-R (which is a long-established Russian font
+encoding, rather than a TeX/LaTeX encoding). To use the fonts, the user needs
+Cyrillic font support.")
+ (license license:lppl)))
+
(define-public texlive-octave
(package
(name "texlive-octave")