summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-28 15:25:58 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-28 15:25:58 +0100
commit3d46e8837ea29ddb800dfd121f518dfdaf8e6a56 (patch)
tree883983e0223d0fde4ef85513b60905c90665a154 /gnu
parent8cd115b67eeeb8e62d58b4b5df076528bed58b5c (diff)
gnu: emacs-shx: Improve packaging style.
* gnu/packages/emacs-xyz.scm (emacs-shx)[arguments]: Use G-expressions. [synopsis, description]: Use proper capitalization.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d042771d77..175b735730 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7014,23 +7014,23 @@ the speedbar window.")
(base32 "1wkqnc5n8if8fsh7f3bdr5nzn6dbj1nzdxlmnz8nflmx4g32fp6v"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:test-command
- '("emacs" "--batch" "--quiet"
- "--script" "test/script.el")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'appease-checkdoc
- (lambda _
- (substitute* "shx.el"
- (("Toggle shx-mode on") "Toggle `shx-mode' on")))))))
+ (list
+ #:tests? #t
+ #:test-command
+ #~(list "emacs" "--batch" "--quiet" "--script" "test/script.el")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'appease-checkdoc
+ (lambda _
+ (substitute* "shx.el"
+ (("Toggle shx-mode on") "Toggle `shx-mode' on")))))))
(home-page "https://github.com/riscy/shx-for-emacs")
- (synopsis "Extras for the comint-mode shell")
+ (synopsis "Extras for the Comint mode shell")
(description
- "This package extends @code{comint-mode}: it parses markup in the output
+ "This package extends Comint mode: it parses markup in the output
stream, enabling plots and graphics to be embedded, and adds command-line
-functions which plug into Emacs (e.g. use @code{:e <filename>} to edit a
-file).")
+functions which plug into Emacs (e.g., use @code{:e <filename>} to edit
+a file).")
(license license:gpl3+))))
(define-public emacs-names