summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:20:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:14 +0200
commit40b8561f5b86a6974efc322d952059b7da453fa7 (patch)
tree46ccc1cb58ba547944aca4dc5355bc737658dbe5 /gnu
parent17ea30f9123940fe62e9399d802670eaf39fc7c8 (diff)
gnu: Add texlive-latexfileinfo-pkgs.
* gnu/packages/tex.scm (texlive-latexfileinfo-pkgs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 83e7439938..a445f88627 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18512,6 +18512,29 @@ the author has give several times at the Rijksuniversiteit
Groningen (Netherlands).")
(license license:fdl1.1+)))
+(define-public texlive-latexfileinfo-pkgs
+ (package
+ (name "texlive-latexfileinfo-pkgs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/latexfileinfo-pkgs/"
+ "source/latex/latexfileinfo-pkgs/"
+ "tex/latex/latexfileinfo-pkgs/")
+ (base32
+ "08afjj6im3bdxv3j0z6kg8yw0pyjl5164fqn0sx084zbdfwdfrqn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/latexfileinfo-pkgs")
+ (synopsis "Comparison of packages showing LaTeX file information")
+ (description
+ "The package provides an HTML file that lists and compares CTAN packages
+that display LaTeX source file information from @code{\\ProvidesClass},
+@code{\\ProvidesFile}, and @code{\\ProvidesPackage} commands in the LaTeX
+file. Five packages of the author's, and several other packages are
+discussed; revision control systems are mentioned briefly.")
+ (license license:lppl1.3+)))
+
(define-public texlive-oberdiek
(package
(name "texlive-oberdiek")