summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:22 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:10:24 +0100
commit417be516def1853d2ef9bf40a31d9eba759451e9 (patch)
tree909bedeb8f3c90acb2e5bfe1452d926db38d2811 /gnu
parentc9865228778941fcee95c501a414e270c6b31fa3 (diff)
gnu: Add ocaml5.0-eio-linux.
* gnu/packages/ocaml.scm (ocaml5.0-eio-linux): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d69ffaa969..30c3d93eaa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2880,6 +2880,29 @@ OCaml with fibers.")
(license
(list license:isc license:expat))))
+(define ocaml-eio-linux
+ (package
+ (inherit ocaml-eio)
+ (name "ocaml-eio-linux")
+ (arguments `(#:package "eio_linux"
+ #:test-target "."))
+ (propagated-inputs
+ (list ocaml-eio
+ ocaml-uring
+ ocaml-logs
+ ocaml-fmt))
+ (native-inputs
+ (list ocaml-mdx
+ ocaml-alcotest
+ ocaml-mdx))
+ (synopsis "Linux backend for ocaml-eio")
+ (description "@code{Eio_linux} provides a Linux io-uring backend for
+@code{Ocaml Eio} APIs, plus a low-level API that can be used directly
+(in non-portable code).")))
+
+(define-public ocaml5.0-eio-linux
+ (package-with-ocaml5.0 ocaml-eio-linux))
+
(define-public ocaml-lwt
(package
(name "ocaml-lwt")