summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-04 22:04:09 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-07 22:34:41 +0000
commit442a35502678c50acdf37fec875b5103d9f2bd8b (patch)
tree62d80344ff7b89d70f9e887307538eb13a56533c /gnu
parentc3d9b4b0979d99d07599d3738ddfb78fca018fa1 (diff)
gnu: r-systempiper: Update to 2.0.0.
* gnu/packages/bioconductor.scm (r-systempiper): Update to 2.0.0. [propagated-inputs]: Remove r-annotate, r-assertthat, r-batchtools, r-deseq2, r-dot, r-edger, r-genomicfeatures, r-go-db, r-gostats, r-iranges, r-limma, r-pheatmap, r-rjson, r-rsvg, r-testthat, and r-variantannotation; add r-biocgenerics and r-htmlwidgets.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 5 insertions, 19 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b7b1b6ae9a..f04e96c23a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4442,44 +4442,30 @@ unmodeled, or latent sources of noise.")
(define-public r-systempiper
(package
(name "r-systempiper")
- (version "1.26.3")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "systemPipeR" version))
(sha256
(base32
- "01l35l5zj87qkarrbal9la6kshk3j7k8hy3iimv3gdnnz4axmvs7"))))
+ "0kibr47z7ml13hpl955qcr4wp2z4nq7gjiinyk30wivrwrng5sg1"))))
(properties `((upstream-name . "systemPipeR")))
(build-system r-build-system)
(propagated-inputs
- `(("r-annotate" ,r-annotate)
- ("r-assertthat" ,r-assertthat)
- ("r-batchtools" ,r-batchtools)
+ `(("r-biocgenerics" ,r-biocgenerics)
("r-biostrings" ,r-biostrings)
("r-crayon" ,r-crayon)
- ("r-deseq2" ,r-deseq2)
- ("r-dot" ,r-dot)
- ("r-edger" ,r-edger)
- ("r-genomicfeatures" ,r-genomicfeatures)
("r-genomicranges" ,r-genomicranges)
("r-ggplot2" ,r-ggplot2)
- ("r-go-db" ,r-go-db)
- ("r-gostats" ,r-gostats)
- ("r-iranges" ,r-iranges)
- ("r-limma" ,r-limma)
+ ("r-htmlwidgets" ,r-htmlwidgets)
("r-magrittr" ,r-magrittr)
- ("r-pheatmap" ,r-pheatmap)
- ("r-rjson" ,r-rjson)
("r-rsamtools" ,r-rsamtools)
- ("r-rsvg" ,r-rsvg)
("r-s4vectors" ,r-s4vectors)
("r-shortread" ,r-shortread)
("r-stringr" ,r-stringr)
("r-summarizedexperiment" ,r-summarizedexperiment)
- ("r-testthat" ,r-testthat)
- ("r-yaml" ,r-yaml)
- ("r-variantannotation" ,r-variantannotation)))
+ ("r-yaml" ,r-yaml)))
(native-inputs
`(("r-knitr" ,r-knitr)))
(home-page "https://github.com/tgirke/systemPipeR")