summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:00:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:16 -0400
commit552076fddf9363fde88cfc4bec9d70d79ca589a2 (patch)
tree2a612880c6abe826c2da5b3721132ce0a495aecb /gnu
parentff70ce499bd391ddd4e09dc9186754ddde885cb7 (diff)
gnu: Remove python2-scientific.
* gnu/packages/python-xyz.scm (python2-scientific): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 0 insertions, 39 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0b9c0201e..34a41cfec2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21652,45 +21652,6 @@ longer maintained. New projects should use Pyro4 instead, which
is the new Pyro version that is actively developed.")
(license license:expat)))
-(define-public python2-scientific
- (package
- (name "python2-scientific")
- (version "2.9.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/khinsen/ScientificPython")
- (commit (string-append "rel" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "16l48aj9fps9r7jyk8gpxppwrv0fqvlc13sayxskz28r5s6sjwbl"))))
- (build-system python-build-system)
- (inputs
- (list netcdf))
- (propagated-inputs
- (list python2-numpy-1.8 python2-pyro))
- (arguments
- ;; ScientificPython is not compatible with Python 3
- `(#:python ,python-2
- #:tests? #f ; No test suite
- #:phases
- (modify-phases %standard-phases
- (replace 'build
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "python" "setup.py" "build"
- (string-append "--netcdf_prefix="
- (assoc-ref inputs "netcdf"))))))))
- (home-page "http://dirac.cnrs-orleans.fr/ScientificPython")
- (synopsis "Python modules for scientific computing")
- (description "ScientificPython is a collection of Python modules that are
-useful for scientific computing. Most modules are rather general (Geometry,
-physical units, automatic derivatives, ...) whereas others are more
-domain-specific (e.g. netCDF and PDB support). The library is currently
-not actively maintained and works only with Python 2 and NumPy < 1.9.")
- (license license:cecill-c)))
-
(define-public python-phonenumbers
(package
(name "python-phonenumbers")