summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 16:56:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:53 +0300
commit5939e141be772949c644f5618b61d6907cb429f4 (patch)
treecf1dd181ec26c398da51584a75c6353e8d81c378 /gnu
parentb5f255949b511c508d1b07ad0fd7c4c923aadd92 (diff)
gnu: Add rust-hashbrown-0.13.
* gnu/packages/crates-io.scm (rust-hashbrown-0.13): New variable. (rust-hashbrown-0.12): Inherit from rust-hashbrown-0.13.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm43
1 files changed, 36 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7ba478b2e1..ebb8fe23ff 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27239,8 +27239,43 @@ already-hashed or hash-like data.")
@code{#[derive(Hash32)]}.")
(license (list license:expat license:asl2.0))))
+(define-public rust-hashbrown-0.13
+ (package
+ (name "rust-hashbrown")
+ (version "0.13.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "hashbrown" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03ji3n19j4b6mf2wlla81vsixcmlivglp6hgk79d1pcxfcrw38s3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ahash" ,rust-ahash-0.8)
+ ("rust-bumpalo" ,rust-bumpalo-3)
+ ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+ ("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-doc-comment" ,rust-doc-comment-0.3)
+ ("rust-fnv" ,rust-fnv-1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-serde-test" ,rust-serde-test-1))))
+ (home-page "https://github.com/rust-lang/hashbrown")
+ (synopsis "Rust port of Google's SwissTable hash map")
+ (description
+ "This package provides a Rust port of Google's SwissTable hash map")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-hashbrown-0.12
(package
+ (inherit rust-hashbrown-0.13)
(name "rust-hashbrown")
(version "0.12.3")
(source (origin
@@ -27257,7 +27292,6 @@ already-hashed or hash-like data.")
'(substitute* "Cargo.toml"
(("\\[package\\]" m)
(string-append "cargo-features = [\"edition2021\"]\n" m))))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-ahash" ,rust-ahash-0.7)
@@ -27273,12 +27307,7 @@ already-hashed or hash-like data.")
("rust-lazy-static" ,rust-lazy-static-1)
("rust-rand" ,rust-rand-0.8)
("rust-rayon" ,rust-rayon-1)
- ("rust-serde-test" ,rust-serde-test-1))))
- (home-page "https://github.com/rust-lang/hashbrown")
- (synopsis "Rust port of Google's SwissTable hash map")
- (description
- "This package provides a Rust port of Google's SwissTable hash map")
- (license (list license:expat license:asl2.0))))
+ ("rust-serde-test" ,rust-serde-test-1))))))
(define-public rust-hashbrown-0.11
(package