summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-21 14:40:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-21 23:12:40 +0100
commit5ccc017389cbb28bf93111225496cf726609b22b (patch)
treebbee1c64d151e16ece64600acd9dc6dfbf6b7d58 /gnu
parentfe5836feaf61a7758c2291d9f665b227de3fa9b7 (diff)
gnu: Add htslib-1.14.
* gnu/packages/bioinformatics.scm (htslib-1.14): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c41cdfbd86..08a7cbe118 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4768,6 +4768,18 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
;; the rest is released under the Expat license
(license (list license:expat license:bsd-3))))
+(define-public htslib-1.14
+ (package/inherit htslib
+ (version "1.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/samtools/htslib/releases/download/"
+ version "/htslib-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0pwk8yhhvb85mi1d2qhwsb4samc3rmbcrq7b1s0jz0glaa7in8pd"))))))
+
(define-public htslib-1.12
(package/inherit htslib
(version "1.12")