summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 20:46:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:33 +0100
commit5e3840e250f89ec8a7cc22ae747e51262edff54c (patch)
tree57547e8714dc433b8b529c27ecc4ad6f88581e2d /gnu
parentc165ff9ce0b4a2c2131132a60663363087532212 (diff)
gnu: ghc-text: Update to 1.2.2.2.
* gnu/packages/haskell.scm (ghc-text): Update to 1.2.2.2. [inputs]: Add ghc-random. squash! gnu: ghc-text: Update to 1.2.3.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0825c55941..4fd6c2f4dd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1731,7 +1731,7 @@ access to the full zlib feature set.")
(define-public ghc-text
(package
(name "ghc-text")
- (version "1.2.1.3")
+ (version "1.2.2.2")
(outputs '("out" "doc"))
(source
(origin
@@ -1742,10 +1742,12 @@ access to the full zlib feature set.")
".tar.gz"))
(sha256
(base32
- "0gzqx5cpkdhshbz9xss51mpyq23pnf8dwjz4h3irbv2ryaa4qdlq"))))
+ "1y9d0zjs2ls0c574mr5xw7y3y49s62sd3wcn9lhpwz8a6q352iii"))))
(build-system haskell-build-system)
- (arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ ;; The test dependencies depend on ghc-text: ghc-test-framework -> ghc-xml -> ghc-text
+ (arguments `(#:tests? #f))
+ (inputs
+ `(("ghc-random" ,ghc-random)))
(home-page "https://github.com/bos/text")
(synopsis "Efficient packed Unicode text type library")
(description