summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-26 10:59:03 +0200
committerAndrew Tropin <andrew@trop.in>2022-11-28 12:50:16 +0400
commit655956131c4208feea3167eac992e8cf204be0d3 (patch)
treeaed83aef2bef6e1e1f3551557d969b44c279c98f /gnu
parent2db12d3c31507d43c4fe5f4de56438411993fa2a (diff)
gnu: Add rust-swayipc-3.
* gnu/packages/crates-io.scm (rust-swayipc-3): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 26 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 97a1fd9b82..e07a8d0cda 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55725,25 +55725,24 @@ values without proliferating generics.")
(description "This package provides custom derive for @code{sval}.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-swayipc-2
+(define-public rust-swayipc-3
(package
(name "rust-swayipc")
- (version "2.7.2")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "swayipc" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "03r15c2sijyrxmpsyjgma4gz7zmdl1g8akjnjkw6hrml91d5dilj"))))
+ (base32 "16pf4r6svf99p73b8dhdannkvhfvmbjb4rx7gifxh8xj53rwy7db"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #f ; test sync::tests::connect ... FAILED
+ `(#:skip-build? #t
#:cargo-inputs
(("rust-serde" ,rust-serde-1)
- ("rust-async-std" ,rust-async-std-1)
- ("rust-swayipc-command-builder" ,rust-swayipc-command-builder-0.1)
- ("rust-serde-json" ,rust-serde-json-1))))
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-swayipc-types" ,rust-swayipc-types-1))))
(home-page "https://github.com/jaycefayne/swayipc-rs")
(synopsis "Library for controlling sway through its IPC interface")
(description
@@ -55751,6 +55750,26 @@ values without proliferating generics.")
interface.")
(license license:expat)))
+(define-public rust-swayipc-2
+ (package
+ (inherit rust-swayipc-3)
+ (name "rust-swayipc")
+ (version "2.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "swayipc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "03r15c2sijyrxmpsyjgma4gz7zmdl1g8akjnjkw6hrml91d5dilj"))))
+ (arguments
+ `(#:tests? #f ; test sync::tests::connect ... FAILED
+ #:cargo-inputs
+ (("rust-serde" ,rust-serde-1)
+ ("rust-async-std" ,rust-async-std-1)
+ ("rust-swayipc-command-builder" ,rust-swayipc-command-builder-0.1)
+ ("rust-serde-json" ,rust-serde-json-1))))))
+
(define-public rust-swayipc-command-builder-0.1
(package
(name "rust-swayipc-command-builder")