summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-09 17:46:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 22:03:27 +0100
commit73545fde4249b160e0c7d0f6da9e55ae0c9f8c47 (patch)
tree6d5b0460b614d84994da3807a14c93de8993b330 /gnu
parent9c3f5b2fa0e57d21c68bda70b5f7b57cd2982ced (diff)
gnu: Add r-parallelly.
* gnu/packages/cran.scm (r-parallelly): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 13e3de2b84..14a2bd751c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12738,6 +12738,34 @@ simple as possible to identify global objects for the purpose of exporting
them in distributed compute environments.")
(license license:lgpl2.1+)))
+(define-public r-parallelly
+ (package
+ (name "r-parallelly")
+ (version "1.21.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "parallelly" version))
+ (sha256
+ (base32
+ "1hlr81khr7z4x9gprymdh19mdq3nw6wm8d2795sd2pa3ya6phnb0"))))
+ (properties `((upstream-name . "parallelly")))
+ (build-system r-build-system)
+ (home-page "https://github.com/HenrikBengtsson/parallelly")
+ (synopsis "Enhancements of the parallel package")
+ (description
+ "This package provides utility functions that enhance the @code{parallel}
+package and support the built-in parallel backends of the @code{future}
+package. For example, @code{availableCores} gives the number of CPU cores
+available to your R process as given by R options and environment variables,
+including those set by job schedulers on high-performance compute clusters.
+If none is set, it will fall back to @code{parallel::detectCores}. Another
+example is @code{makeClusterPSOCK}, which is backward compatible with
+@code{parallel::makePSOCKcluster} while doing a better job in setting up
+remote cluster workers without the need for configuring the firewall to do
+port-forwarding to your local computer.")
+ (license license:lgpl2.1+)))
+
(define-public r-future
(package
(name "r-future")