summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:15 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:08:54 +0100
commit74f5ddef813b38e26ea0a6339fe732670b8ad8bc (patch)
tree9e1272fd82241d8d60a46210e4ec136cf9d8ab0b /gnu
parent048217e73c9ed6459ec8252163335c2982deefc6 (diff)
gnu: Add ocaml-lwt-dllist.
* gnu/packages/ocaml.scm (ocaml-lwt-dllist): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1ca3c19842..cb845b7ead 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2826,6 +2826,27 @@ process. Also, in many cases, Lwt threads can interact without the need for
locks or other synchronization primitives.")
(license license:lgpl2.1)))
+(define-public ocaml-lwt-dllist
+ (package
+ (name "ocaml-lwt-dllist")
+ (version "1.0.1")
+ (home-page "https://github.com/mirage/lwt-dllist")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18bi8fb4yly1pyf43pjvvdhlyzb3wkgxifffx9d1g9y2mwsng6jw"))))
+ (build-system dune-build-system)
+ (native-inputs (list ocaml-lwt))
+ (synopsis "OCaml library providing mutable doubly-linked list with Lwt iterators")
+ (description "This OCaml library provides an implementation of a mutable
+doubly-linked list with Lwt iterators.")
+ (license license:expat)))
+
(define-public ocaml-luv
(package
(name "ocaml-luv")