summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:22:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:12 +0200
commit78c3982c61ff609455f1d7694c2a805d7ae1b458 (patch)
tree78fb98e75022af2accd66f838f415b739472e4ce /gnu
parent57d358455d1c83d5d1a1ddc7199bc5f9ca28f3d1 (diff)
gnu: Add texlive-gnu-freefont.
* gnu/packages/tex.scm (texlive-gnu-freefont): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cb93e5e15f..9e85d1c15f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13346,6 +13346,29 @@ a possibility of optical centering and right-hanging alignment of lines broken
because of length.")
(license license:lppl)))
+(define-public texlive-gnu-freefont
+ (package
+ (name "texlive-gnu-freefont")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/gnu-freefont/"
+ "fonts/opentype/public/gnu-freefont/"
+ "fonts/truetype/public/gnu-freefont/"
+ "source/fonts/gnu-freefont/")
+ (base32
+ "14bq8i7n6zhy8352pmhd5d9l4p152c6bgarz17wfp2p00kzs47aw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/gnu-freefont")
+ (synopsis "Unicode font, with rather wide coverage")
+ (description
+ "The package provides a set of outline (i.e., OpenType} fonts covering as
+much as possible of the Unicode character set. The set consists of three
+typefaces: one monospaced and two proportional (one with uniform and one with
+modulated stroke).")
+ (license license:gpl3)))
+
(define-public texlive-go
(package
(name "texlive-go")