summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:04 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:18 -0500
commit815821c139798e42e2c022a5c2128ea10e9d2fea (patch)
tree8329cd41c03743516a3f38a12890a4f4f3edcce0 /gnu
parentd0dc31a56ec497e070eb6662c8ff6b4b3e5c7cef (diff)
gnu: go-github-com-google-safehtml: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-google-safehtml): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ia1f14486f262d3695077c8e2f409f4928874c4f8
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm26
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 117742dc07..ce95d1b467 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
@@ -146,6 +147,31 @@ metrics (i.e. response time, bytes written, and http status code) from your
application's http.Handlers.")
(license license:expat)))
+(define-public go-github-com-google-safehtml
+ (package
+ (name "go-github-com-google-safehtml")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/safehtml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j2xjy8xrk9y9k6bqpvimj84i6hg1wwsyvwsb0axhmp49cmnrp86"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/safehtml"))
+ (propagated-inputs `(("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (home-page "https://github.com/google/safehtml")
+ (synopsis "Safe HTML for Go")
+ (description
+ "Package safehtml provides immutable string-like types which represent
+values that are guaranteed to be safe, by construction or by escaping or
+sanitization, to use in various HTML contexts and with various DOM APIs.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gorilla-context
(let ((commit "08b5f424b9271eedf6f9f0ce86cb9396ed337a42")
(revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 292d4f799d..84dead6293 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12510,31 +12510,6 @@ production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
-(define-public go-github-com-google-safehtml
- (package
- (name "go-github-com-google-safehtml")
- (version "0.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/safehtml")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0j2xjy8xrk9y9k6bqpvimj84i6hg1wwsyvwsb0axhmp49cmnrp86"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/google/safehtml"))
- (propagated-inputs `(("go-golang-org-x-text" ,go-golang-org-x-text)))
- (home-page "https://github.com/google/safehtml")
- (synopsis "Safe HTML for Go")
- (description
- "Package safehtml provides immutable string-like types which represent values
-that are guaranteed to be safe, by construction or by escaping or sanitization,
-to use in various HTML contexts and with various DOM APIs.")
- (license license:bsd-3)))
-
(define-public go-github-com-google-shlex
(package
(name "go-github-com-google-shlex")