summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:03:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:21 -0400
commit9702e5f26cf4bac6ceb909c271d39c6889e52663 (patch)
tree4fffc514213aa48710d2700b1cb9f85a8278a469 /gnu
parent745be53c5f6bdbd221e6e3f33e04e5016b7c7c15 (diff)
gnu: Remove python2-pep517.
* gnu/packages/python-xyz.scm (python2-pep517): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 8 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 99c3e8d1ac..a6b36ea44a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10807,30 +10807,15 @@ plugin for flake8 to check PEP-8 naming conventions.")
(inherit python-pep517-bootstrap)
(name "python-pep517")
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (delete-file "pytest.ini")
- ;; This test tries to connect to the internet
- (delete-file "tests/test_meta.py")
- (if tests?
- (invoke "pytest")
- #t))))))
- (native-inputs
- (list python-mock python-pytest python-testpath))
- (properties `((python2-variant . ,(delay python2-pep517))))))
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (delete-file "pytest.ini")
+ (delete-file "tests/test_meta.py")
+ (if tests?
+ (invoke "pytest") #t))))))
+ (native-inputs (list python-mock python-pytest python-testpath))))
-;; Skip the tests so we don't create a cyclical dependency with pytest.
-(define-public python2-pep517
- (let ((base (package-with-python2
- (strip-python2-variant python-pep517))))
- (package/inherit base
- (name "python2-pep517")
- (arguments
- `(#:tests? #f
- ,@(package-arguments base)))
- (native-inputs `()))))
(define-public python-pep621
(package