summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:08:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:24 +0200
commit98348a43791890f1247aec95c245e064e36de91b (patch)
tree8707f27c6e0038586914810206ae1c2a9e0365ce /gnu
parent6cb645b73bbeffffa659deee8c01c8e763927412 (diff)
gnu: Add trytond-account-asset.
* gnu/packages/tryton.scm (trytond-account-asset): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 364544c6d9..3c44425ba7 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -215,6 +215,33 @@ most of accounting needs.")
(define-public python-trytond-account
(deprecated-package "python-trytond-account" trytond-account))
+(define-public trytond-account-asset
+ (package
+ (name "trytond-account-asset")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_asset" version))
+ (sha256
+ (base32 "12qf6f4hpxi6c3mx18d07ljbzzr58h0lg8yz95nby3g3mpx2mlaz"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_asset"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-purchase" ,trytond-purchase)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-account-invoice" ,trytond-account-invoice)
+ ("trytond-account-product" ,trytond-account-product)
+ ("trytond-product" ,trytond-product)))
+ (home-page "https://docs.tryton.org/projects/modules-account-asset")
+ (synopsis "Tryton module for assets management")
+ (description "The @emph{Account Asset} Tryton module adds the depreciation
+of fixed assets.")
+ (license license:gpl3+)))
+
(define-public trytond-account-invoice
(package
(name "trytond-account-invoice")