summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 18:56:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:14:31 +0200
commit9bb94927641ba0a6ab496973150ceb50d8402405 (patch)
treeb854c3bd3ec434beb6ed895cd15c2251c38780aa /gnu
parent72c3e4cdb1202273f2d88848bb7625a57c5da65c (diff)
gnu: Add texlive-cjk-ko.
* gnu/packages/tex.scm (texlive-cjk-ko): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8ef9afe339..40c569f1d5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4148,6 +4148,27 @@ privileges, a run without arguments should result in a complete setup of
Ghostscript.")
(license license:gpl3)))
+(define-public texlive-cjk-ko
+ (package
+ (name "texlive-cjk-ko")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/cjk-ko/" "tex/latex/cjk-ko/")
+ (base32
+ "0z94rrbr56kybvxx37hpncc0rj4v4i44kyb9nc42nb7854y8zl0a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-cjk))
+ (home-page "https://ctan.org/pkg/cjk-ko")
+ (synopsis "Extension of the CJK package for Korean typesetting")
+ (description
+ "The package supports typesetting UTF-8-encoded modern Korean documents
+with the help of the LaTeX2e CJK package. It provides some enhanced features
+focused on Korean typesetting culture, one of them being allowing line-break
+between Latin and CJK characters.")
+ (license (list license:gpl3+ license:lppl license:public-domain))))
+
(define-public texlive-cjkpunct
(package
(name "texlive-cjkpunct")