summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:24:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:46 +0200
commita9ea71d9f6ca017ebe92c282e5e6e2da7bd2c77f (patch)
treee1bd0a4e446e7cd5f4440bb2d054445351118223 /gnu
parent4cd398c8b521610488b6ae21f3d7864def674382 (diff)
gnu: Add texlive-tex4ebook.
* gnu/packages/tex.scm (texlive-tex4ebook): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9b89085384..65d68defed 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6202,6 +6202,28 @@ TeX4ht to approach the robustness characteristic of restricted-syntax systems
such as @code{gellmu}.")
(license license:lppl)))
+(define-public texlive-tex4ebook
+ (package
+ (name "texlive-tex4ebook")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/tex4ebook/"
+ "scripts/tex4ebook/" "tex/latex/tex4ebook/")
+ (base32
+ "0907df4hb9y7nh5bz450qb1ljixk5li8hp6r9ajx8d0c47ac5a8v")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "tex4ebook")))
+ (propagated-inputs (list texlive-make4ht texlive-tex4ht))
+ (home-page "https://ctan.org/pkg/tex4ebook")
+ (synopsis "Converter from LaTeX to EBook formats")
+ (description
+ "This is a bundle of Lua scripts and LaTeX packages for conversion of
+LaTeX files to EBook formats such as EPUB, MOBI and EPUB3. TeX4ht is used as
+the conversion engine.")
+ (license license:lppl1.3+)))
+
(define-public texlive-texdraw
(package
(name "texlive-texdraw")