summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-03 17:30:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-04 23:13:51 +0100
commitab64815f6ab11fb18805ca0f04530e31f85bddd5 (patch)
treeb66d3b30bf5f4263de217fba3ddd3d08c81e67f9 /gnu
parent3f991b817d350fb1f566205db6171cdd6162aa12 (diff)
gnu: Add r-truncdist.
* gnu/packages/cran.scm (r-truncdist): New variable. Change-Id: Icb9f06a36e5ee5a58828dc2f496b71a850a911b9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 648dc87de3..899a41e337 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8975,6 +8975,30 @@ distribution with mean equal to @code{mean} and standard deviation equal to
functions, as well as a random generation function.")
(license license:gpl2)))
+(define-public r-truncdist
+ (package
+ (name "r-truncdist")
+ (version "1.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "truncdist" version))
+ (sha256
+ (base32 "02ihw4ixhadwr3sqm6r264i8vpcaz8pn69vkzabd8fwqvn5vcj5q"))))
+ (properties `((upstream-name . "truncdist")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-evd))
+ (home-page "https://cran.r-project.org/package=truncdist")
+ (synopsis "Truncated random variables")
+ (description
+ "This package provides a collection of tools to evaluate probability density
+functions, cumulative distribution functions, quantile functions and random
+numbers for truncated random variables. These functions are provided to also
+compute the expected value and variance. @acronym{Q-Q, quantile–quantile} plots
+can be produced. All the probability functions in the stats, stats4 and evd
+packages are automatically available for truncation.")
+ (license license:gpl2+)))
+
(define-public r-rsolnp
(package
(name "r-rsolnp")