summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 21:06:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:11 +0300
commitb08c1f86175ca8a95f471cf1d62aa4d69fe0193d (patch)
tree22824272baa35694c972fc7b24b45c2df69c3ae8 /gnu
parente56b33b784a046756572d68be3c2a513e21e4f9d (diff)
gnu: Add rust-regex-test-0.1.
* gnu/packages/crates-io.scm (rust-regex-test-0.1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fbe96ac618..757d669816 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -52200,6 +52200,31 @@ uses finite automata and guarantees linear time matching on all inputs.")
(("rust-quickcheck" ,rust-quickcheck-0.2)
("rust-rand" ,rust-rand-0.3))))))
+(define-public rust-regex-test-0.1
+ (package
+ (name "rust-regex-test")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "regex-test" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "012nj2qjkxlv5zmnk53hc5a95kdsz8ss469s0a6fp5xdqbpi9f8l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-bstr" ,rust-bstr-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-toml" ,rust-toml-0.7))))
+ (home-page "https://github.com/rust-lang/regex/tree/master/regex-test")
+ (synopsis "Infrastructure for testing regexes")
+ (description
+ "Infrastructure for testing regexes. You probably don't want to use this
+crate unless you're working on a regex implementation.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-region-3
(package
(name "rust-region")