summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-10 09:20:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:41 +0200
commitb52fd4080265ffeba360567ba7de6cb210bda4b7 (patch)
tree0e219198a32fc2b2d676a1ade8f83f7cd3df5f91 /gnu
parent568da2eb97d78e6628ab5099087bc14f0f3a2d99 (diff)
gnu: Add texlive-mafr.
* gnu/packages/tex.scm (texlive-mafr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 58d13f8b69..3378b3d874 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5587,6 +5587,44 @@ inside the same directory. This document is not yet complete in content and
format and may miss some macros.")
(license license:lppl1.3c)))
+(define-public texlive-mafr
+ (package
+ (name "texlive-mafr")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mafr/" "tex/latex/mafr/")
+ (base32
+ "0bzmf36xy2ppd2bkc5lkcw43jangwn0w4scgr9il06d14lbw68yn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mafr")
+ (synopsis "Mathematics in accord with French usage")
+ (description
+ "The package provides settings and macros for typesetting mathematics
+with LaTeX in compliance with French usage. It comes with two document
+classes, @code{fiche} and @code{cours}, useful to create short high school
+documents such as tests or lessons. The documentation is in French.")
+ (license license:gpl3+)))
+
+(define-public texlive-matapli
+ (package
+ (name "texlive-matapli")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/matapli/" "tex/latex/matapli/")
+ (base32
+ "0khkgc80hbydnlciqr02ay88gazr4nxdq099pjgf1xcjlnlmnwcp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/matapli")
+ (synopsis "Class for the French journal @emph{MATAPLI}")
+ (description
+ "This is a class for the French journal @emph{MATAPLI} of the Société de
+Mathématiques Appliquées et Industrielles (SMAI).")
+ (license license:lppl1.3c)))
+
(define-public texlive-math-into-latex-4
(package
(name "texlive-math-into-latex-4")