summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:52 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:15 -0500
commitb870f17a83f9a17e0f4677cf0f8303d120106328 (patch)
tree0da31aaa544aeed8b5525916512bbfcf65fc7c9f /gnu
parent1754f847aa854d004348a6d1090b0132ad87055a (diff)
gnu: go-github-com-gorilla-sessions: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-sessions): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ic4cc128724583a7c50102e476c6b96ea4e322bdd
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm27
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1a77e0f6f2..971b370115 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -236,6 +237,32 @@ cookie values")
encrypted cookie values for Go web applications.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-sessions
+ (package
+ (name "go-github-com-gorilla-sessions")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/sessions")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zjw2s37yggk9231db0vmgs67z8m3am8i8l4gpgz6fvlbv52baxp"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gorilla/sessions"))
+ (propagated-inputs
+ (list go-github-com-gorilla-securecookie))
+ (home-page "https://github.com/gorilla/sessions")
+ (synopsis "Manage user sessions in web applications")
+ (description
+ "This package that provides infrastructure for creating and managing user
+sessions in web applications. It supports cookie and filesystem-based
+sessions, flash messages, custom backends, and more.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gorilla-websocket
(package
(name "go-github-com-gorilla-websocket")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 53ae15e2e2..14b6fef71d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4867,31 +4867,6 @@ the @code{c2go} tool at
@url{https://github.com/andybalholm/c2go,https://github.com/andybalholm/c2go}.")
(license license:expat)))
-(define-public go-github-com-gorilla-sessions
- (package
- (name "go-github-com-gorilla-sessions")
- (version "1.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gorilla/sessions")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1zjw2s37yggk9231db0vmgs67z8m3am8i8l4gpgz6fvlbv52baxp"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/gorilla/sessions"))
- (propagated-inputs (list go-github-com-gorilla-securecookie))
- (home-page "https://github.com/gorilla/sessions")
- (synopsis "Manage user sessions in web applications")
- (description
- "This package that provides infrastructure for creating and
-managing user sessions in web applications. It supports cookie and
-filesystem-based sessions, flash messages, custom backends, and more.")
- (license license:bsd-3)))
-
(define-public go-github-com-gorilla-csrf
(package
(name "go-github-com-gorilla-csrf")