summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:17:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:38 +0200
commitbac5097052326660735bdb6613fdf268c9b6c7bc (patch)
tree55e7ff1a96b85d78da17d70e37db4fb41692a924 /gnu
parentfa16e8fe36637b03257d09f48b9691984078b84f (diff)
gnu: Add texlive-luajittex.
* gnu/packages/tex.scm (texlive-luajittex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 202175ddd0..8c5b800d54 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2811,6 +2811,37 @@ environments and another with all extracted environments converted to
@code{\\includegraphics}.")
(license license:gpl3+)))
+(define-public texlive-luajittex
+ (package
+ (name "texlive-luajittex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/luajithbtex.1"
+ "doc/man/man1/luajithbtex.man1.pdf"
+ "doc/man/man1/luajittex.1"
+ "doc/man/man1/luajittex.man1.pdf")
+ (base32
+ "1qfbg0r6gsncgymh00yc83kcayd4m7bvryap8f63sm9s9bzfl6yv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "luajithbtex" "luajittex")))
+ (propagated-inputs
+ (list texlive-cm
+ texlive-etex
+ texlive-hyphen-complete
+ texlive-knuth-lib
+ texlive-luatex
+ texlive-plain
+ texlive-tex-ini-files
+ texlive-unicode-data))
+ (home-page "https://ctan.org/pkg/luajittex")
+ (synopsis "LuaTeX with JIT compiler, with and without HarfBuzz")
+ (description
+ "This package provides LuaTeX with just-in-time (JIT) compiler, with and
+without HarfBuzz.")
+ (license license:gpl2)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")