summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-04-23 18:45:45 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-23 22:40:51 +0200
commitbc36da14260916748ee8ae14e99c412d3dd8e9f1 (patch)
treef3f043f86423ea6c2bd0944f95a1c69052537c81 /gnu
parentd7ec2805fbb7fe39e2c66588baef0454aeb42548 (diff)
gnu: python-pydevd: Skip three failing tests.
* gnu/packages/python-xyz.scm (python-pydevd)[arguments]: In 'check' phase, skip a couple more tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c623ce3135..be1ab2813f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2017, 2021, 2022 Eric Bavier <bavier@posteo.net>
@@ -13675,8 +13675,14 @@ libmagic.")))
"-n" (number->string (parallel-job-count))
"-k"
(string-append
+ ;; The two "break_01" tests have been failing on
+ ;; Python 3.10:
+ ;; <https://github.com/fabioz/PyDev.Debugger/issues/222>.
+ "not test_set_pydevd_break_01 "
+ ;; This one fails for unknown reasons.
+ "and not test_completion_sockets_and_messages "
;; the GUI event loop requires an X server.
- "not test_gui_event_loop_custom "
+ "and not test_gui_event_loop_custom "
;; This test validates that 'pydevd' is not in the
;; exception message, but it is due to being part
;; of the build file name present in the message.