summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 14:05:57 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:51 +0530
commitc054ae40f45c23df16cd344d3b28832fedfe2f1c (patch)
treeda37f9ab88a316df08f74b913aefd3242b993382 /gnu
parent5872e71db7e0542a8011d3b34dc56aa44ffae9bf (diff)
gnu: Add rust-hash32-0.1.
* gnu/packages/crates-io.scm (rust-hash32-0.1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2a93d77c50..c35b122862 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10060,6 +10060,29 @@ IEEE 754-2008 binary16 type.")
the template engine that renders the official Rust website")
(license license:expat)))
+(define-public rust-hash32-0.1
+ (package
+ (name "rust-hash32")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hash32" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k7lv7hsbzv14pz90cxay6v7avh6d6kcrra0rsc45b33dvw1l16l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1))
+ #:cargo-development-inputs
+ (("rust-hash32-derive" ,rust-hash32-derive-0.1))))
+ (home-page "https://github.com/japaric/hash32")
+ (synopsis "32-bit hashing machinery")
+ (description "This package provides 32-bit hashing machinery.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-hash32-derive-0.1
(package
(name "rust-hash32-derive")