summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 22:49:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:46 +0200
commitc5b02655200954326641825602cdffb7879f885c (patch)
treee10faeb176acb490a45e2627beabdba7abbb5ef6 /gnu
parent21dbe0812d5522bc5be85416ab634391d9266af7 (diff)
gnu: texlive-refcount: Refresh package definition.
* gnu/packages/tex.scm (texlive-refcount): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-INFWARERR, TEXLIVE-LTXCMDS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ef8335f7f5..97613e6595 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5718,31 +5718,28 @@ re-processing.")
(define-deprecated-package texlive-latex-pstool texlive-pstool)
(define-public texlive-refcount
- (let ((template (simple-texlive-package
- "texlive-refcount"
- (list "doc/latex/refcount/"
- "source/latex/refcount/"
- "tex/latex/refcount/")
- (base32
- "128cvwdl4wcdshvs59yn5iljdxxdrc5jircbxav77y7kc3l33z7z"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "latex/refcount")
- ((#:build-targets _ '())
- #~(list "refcount.dtx"))))
- (home-page "https://www.ctan.org/pkg/refcount")
- (synopsis "Counter operations with label references")
- (description
- "This package provides the @code{\\setcounterref} and
+ (package
+ (name "texlive-refcount")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/refcount/" "source/latex/refcount/"
+ "tex/latex/refcount/")
+ (base32
+ "128cvwdl4wcdshvs59yn5iljdxxdrc5jircbxav77y7kc3l33z7z")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-infwarerr texlive-ltxcmds))
+ (home-page "https://www.ctan.org/pkg/refcount")
+ (synopsis "Counter operations with label references")
+ (description
+ "This package provides the @code{\\setcounterref} and
@code{\\addtocounterref} commands which use the section (or other) number
from the reference as the value to put into the counter. It also provides
@code{\\setcounterpageref} and @code{\\addtocounterpageref} that do the
corresponding thing with the page reference of the label.")
- (license license:lppl1.3c+))))
+ (license license:lppl1.3c+)))
(define-deprecated-package texlive-latex-refcount texlive-refcount)