summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:07:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:33:10 +0200
commitc8b759d9a8fde43d07125d3fdbd44616bb1f47bb (patch)
tree526150e4f2cf77c8896cb8142b3057c1d5f8bd9e /gnu
parent356df215e64aa110dd1a96eec496c74f09e122e2 (diff)
gnu: Add texlive-latexbangla.
* gnu/packages/tex.scm (texlive-latexbangla): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1e3b7cbc35..431022ca4f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16528,6 +16528,36 @@ document knows basic (La)TeX or has, at least, tried her hand on it. This
document is not very suitable for first time users.")
(license license:lppl1.3+)))
+(define-public texlive-latexbangla
+ (package
+ (name "texlive-latexbangla")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/latexbangla/"
+ "tex/latex/latexbangla/")
+ (base32
+ "19h1axbfp1xclbhffdiczzqpr4lk2jw8kkz4qqh8f2rnhjxd94vw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/latexbangla")
+ (synopsis "Enhanced LaTeX integration for Bangla")
+ (description
+ "This package simplifies the process of writing Bangla in LaTeX and
+addresses most of the associated typesetting issues. Its notable features
+are:
+
+@itemize
+@item automated transition from Bangla to English and vice versa;
+@item patch for the unproportionate whitespace issue in popular Bangla fonts;
+@item full support for all the common commands and environments;
+@item Bangla numbering for page, section, chapter, footnotes, extending
+Polyglossia's support.
+@item new @code{theorem}, @code{problems}, @code{example}, @code{solution} and
+other environments, all of which are in Bangla.
+@end itemize")
+ (license license:lppl1.3+)))
+
(define-public texlive-liftarm
(package
(name "texlive-liftarm")