summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 11:55:23 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:17 +0200
commitceebedc4337a041461134588288a7121302ae6ae (patch)
treef95847e18db9e23e79d851c36a31b14e7d219c1d /gnu
parentbd4aeaf152d5d96a1570550f5366d936da3684c8 (diff)
gnu: Add rust-tokio-current-thread-0.1.
* gnu/packages/crates-io.scm (rust-tokio-current-thread-0.1): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 458d2abbb5..acdbb1a2df 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5069,6 +5069,33 @@ in Rust.")
"Utilities for encoding and decoding frames.")
(license license:expat)))
+(define-public rust-tokio-current-thread-0.1
+ (package
+ (name "rust-tokio-current-thread")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tokio-current-thread" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hx4c8v88kk0ih8x5s564gsgwwf8n11kryvxm72l1f7isz51fqni"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-futures" ,rust-futures-0.1)
+ ("rust-tokio-executor" ,rust-tokio-executor-0.1))))
+ (home-page "https://github.com/tokio-rs/tokio")
+ (synopsis
+ "Manage many tasks concurrently on the current thread")
+ (description
+ "Single threaded executor which manage many tasks concurrently on
+the current thread.")
+ (license license:expat)))
+
;; Cyclic dependency with rust-tokio.
(define-public rust-tokio-executor-0.1
(package