summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-09 17:48:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 22:03:28 +0100
commitd106e3e7f6247a9a54cc5b8ea17da5aaf591889e (patch)
tree967755ddf7328f6969df3d8564ca4e9b856dcf69 /gnu
parentfab49665bbeba23dff45beafbab34a1413ae77e7 (diff)
gnu: Add r-projpred.
* gnu/packages/cran.scm (r-projpred): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 85b1dec362..cf09080855 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22889,6 +22889,45 @@ safeguarded Newton methods. Many methods previously separate are now included
here.")
(license license:gpl2)))
+(define-public r-projpred
+ (package
+ (name "r-projpred")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "projpred" version))
+ (sha256
+ (base32
+ "0nx514mrfh3gv854pr71w5x3zgdnn0kinf5nh7z90q3h7ysry2mg"))))
+ (properties `((upstream-name . "projpred")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-gamm4" ,r-gamm4)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-lme4" ,r-lme4)
+ ("r-loo" ,r-loo)
+ ("r-magrittr" ,r-magrittr)
+ ("r-mass" ,r-mass)
+ ("r-mgcv" ,r-mgcv)
+ ("r-optimx" ,r-optimx)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-rngtools" ,r-rngtools)
+ ("r-rstantools" ,r-rstantools)
+ ("r-tidyverse" ,r-tidyverse)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://mc-stan.org/projpred/")
+ (synopsis "Projection predictive feature selection")
+ (description
+ "This package performs projection predictive feature selection for
+generalized linear models and generalized linear and additive multilevel
+models. The package is compatible with the @code{rstanarm} and @code{brms}
+packages, but other reference models can also be used. See the package
+vignette for more information and examples.")
+ (license license:gpl3)))
+
(define-public r-brms
(package
(name "r-brms")