summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 16:30:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:51 +0300
commite23392b700fb20aa08c4abfed7d9b73b488e443b (patch)
treef08b8d47c47678080971ab6abf8a2eb054d3d42e /gnu
parentf2359e14a7fd3b2eb249d1ddeeeb2603cc79c10d (diff)
gnu: Add rust-botan-src-0.21903.
* gnu/packages/crates-io.scm (rust-botan-src-0.21903): New variable. (rust-botan-src-0.21703): Inherit from rust-botan-src-0.21903.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 09c7d5759d..6ff9e797cc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8276,17 +8276,17 @@ programs.")
(description "FFI wrapper for Botan cryptography library")
(license license:expat)))
-(define-public rust-botan-src-0.21703
+(define-public rust-botan-src-0.21903
(package
(name "rust-botan-src")
- (version "0.21703.0")
+ (version "0.21903.1")
(source (origin
(method url-fetch)
(uri (crate-uri "botan-src" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0s2ad9q84qsrllfsbj7hjhn7gr3hab9ng6lwzwqmimia6yvja8y8"))
+ "19fhll4g0v8hbyjxg8c790l9ln5xgf4r6xdcnw438mpy81hvrdxy"))
(modules '((guix build utils)))
(snippet
'(begin (delete-file-recursively "botan")))))
@@ -8297,6 +8297,22 @@ programs.")
(description "Sources of Botan cryptography library")
(license license:expat)))
+(define-public rust-botan-src-0.21703
+ (package
+ (inherit rust-botan-src-0.21903)
+ (name "rust-botan-src")
+ (version "0.21703.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "botan-src" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0s2ad9q84qsrllfsbj7hjhn7gr3hab9ng6lwzwqmimia6yvja8y8"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (delete-file-recursively "botan")))))))
+
(define-public rust-boxfnonce-0.1
(package
(name "rust-boxfnonce")