summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-23 17:15:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:18 +0300
commite39b8ae5aac8abf65140042f9cc076fac0ec4e71 (patch)
tree2da1a98a6ec3bb28de6d6eab8d7371728042c75f /gnu
parent3e9cf5155b47a7926248e376af06829240f9d169 (diff)
gnu: Add rust-serde-big-array-0.4.
* gnu/packages/crates-io.scm (rust-serde-big-array-0.4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f4db600b35..2e7217939d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53521,6 +53521,28 @@ fragment of code.")
(("rust-clippy" ,rust-clippy-0.0))
#:tests? #f))))
+(define-public rust-serde-big-array-0.4
+ (package
+ (name "rust-serde-big-array")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "serde-big-array" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1rwhbrffdxy87bxbyx8p68cg30gf0dlflx14vk1qiwlafjdg08rk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://github.com/est31/serde-big-array")
+ (synopsis "Big array helper for serde")
+ (description "Big array helper for serde.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-serde-big-array-0.3
(package
(name "rust-serde-big-array")