summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:00:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:00:34 +0200
commite4aba0f472b2ee43584456bd4f5637debc105bcb (patch)
treed870ef8e0f0b615ea93f1c72d141011899727c9e /gnu
parent99c6d3e5207053518100b398af132cc423b67521 (diff)
gnu: Add texlive-ptex2pdf.
* gnu/packages/tex.scm (texlive-ptex2pdf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e38e1ba291..7209073ec2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15069,6 +15069,27 @@ for (u)ptex and related programs and formats.")
@command{makejvf} program.")
(license license:bsd-3)))
+(define-public texlive-ptex2pdf
+ (package
+ (name "texlive-ptex2pdf")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ptex2pdf/" "scripts/ptex2pdf/")
+ (base32
+ "0vc4clig35s9cir2gmls7zvj8k1qal4np0akvlgsz2zch44b0imr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ptex2pdf.lua")))
+ (home-page "https://ctan.org/pkg/ptex2pdf")
+ (synopsis "Convert Japanese TeX documents to PDF")
+ (description
+ "The Lua script provides system-independent support of Japanese
+typesetting engines in TeXworks. As TeXworks typesetting setup does not allow
+for multistep processing, this script runs one of the pTeX-based programs
+followed by dvipdfmx.")
+ (license license:gpl2)))
+
(define-public texlive-pwebmac
(package
(name "texlive-pwebmac")