summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-22 18:13:10 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:09 +0100
commite528b5eea34a39d944cdb11900a49f68dd396c54 (patch)
tree6960da96d55483972ee515a6677d5fd719a71189 /gnu
parent8ca39d7a125254a8bb6740bf29eb1404014b14ca (diff)
gnu: Add kscreen.
* gnu/packages/kde-plasma.scm (kscreen): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-plasma.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 8b3e525b07..32fd21da0d 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -164,6 +165,47 @@ manager which re-parents a Client window to a window decoration frame.")
(home-page "https://invent.kde.org/plasma/kgamma5")
(license license:gpl2+)))
+(define-public kscreen
+ (package
+ (name "kscreen")
+ (version "5.25.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version "/" name "-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "0361202n0366jiyv61w06jikh2i4s1fzr6x3chmdykx4fgvbqj7s"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; TODO: All tests fail
+ (list #:tests? #f))
+ (native-inputs (list extra-cmake-modules qttools-5 pkg-config))
+ (inputs (list kconfig
+ kdbusaddons
+ kdeclarative
+ kglobalaccel
+ ki18n
+ kwindowsystem
+ kiconthemes
+ kcoreaddons
+ kcmutils
+ kxmlgui
+ libkscreen
+ libxi
+ plasma-wayland-protocols
+ qtsensors
+ qtbase-5
+ qtx11extras
+ xcb-util))
+ (propagated-inputs (list plasma-framework))
+ (home-page "https://invent.kde.org/plasma/kscreen")
+ (synopsis "Screen management software")
+ (description "This package provides the screen management software for
+KDE Plasma Workspaces.")
+ (license license:gpl2+)))
+
(define-public ksshaskpass
(package
(name "ksshaskpass")