summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:32:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:42:52 +0200
commite77bb3c9491e2dd716e53d12c09949e149814df2 (patch)
tree06e95f72bdf54311b78b73742529495739ce0450 /gnu
parent5c2d76397d25f7defa5982a769c50dac1b9604b8 (diff)
gnu: Add texlive-tram.
* gnu/packages/tex.scm (texlive-tram): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8f8f6b5139..099b411aa4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22165,6 +22165,27 @@ cobordisms between circles, such as those used in TQFT and other mathematical
diagrams.")
(license license:lppl1.3+)))
+(define-public texlive-tram
+ (package
+ (name "texlive-tram")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tram/"
+ "fonts/source/public/tram/"
+ "tex/latex/tram/")
+ (base32
+ "1b26615dd1qs12vl9d82xcxlc718s5jgirzygss9g7m908w2hqch")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tram")
+ (synopsis "Typeset tram boxes in LaTeX")
+ (description
+ "Tram boxes are highlighted with patterns of dots; the package defines an
+environment @code{tram} that typesets its content into a tram box. The
+pattern used may be selected in an optional argument to the environment.")
+ (license license:lppl)))
+
(define-public texlive-tsemlines
(package
(name "texlive-tsemlines")